Skip to main content

Scalars

Scalars are primitive values: Int, Float, String, Boolean, or ID.

When calling the GraphQL API, you must specify nested subfields until you return only scalars.

Key​

Represents a Base64 encoded string that is a unique identifier of an object.


String​

Represents a textual data as UTF-8 character sequences.


Boolean​

Represents true or false values.


Float​

Represents a signed decimal value.


Int​

Represents a signed integer that is at most 32 bits in size.


Int64​

Represents a signed integer that is at most 64 bits in size.


Uint​

Represents an unsigned integer that is at most 32 bits in size.


Uint64​

Represents an unsigned integer that is at most 64 bits in size.


Money​

Represents a signed double-precision which follow the format of 0.00. Ex: 123.53.


URI​

An RFC3986, RFC3987, and RFC6570 (level 4) compliant URI string.


Date​

An ISO 8601 date string, using the format of YYYY-MM-DD. Ex: 2006-06-22.


DateTime​

An RFC3339 UTC date time string. Ex: 2019-10-12T07:20:50.52Z.


State​

An ISO 3166-2 state code string. Ex: MY-14 for Kuala Lumpur.


Country​

An ISO 3166-1 alpha-3 country code string. Ex: MYS for Malaysia.


Language​

A BCP 47 language tag string. Ex: en for English.

The possible values that this type may have are as following:

ValueDescription
msMalay
taTamil
koKorean
jaJapanese
teTelugu
thThai
hiHindi
zhChinese
zh-hkCantonese
deGerman
frFrench
idIndonesian
viVietnamese
arArabic
bnBangladesh
trTurkish